Le HTTPS...

Soucis de programmation et proposition de scripts.
3 message(s)Page 1 sur 1

Le HTTPS...

Messagepar uniteailee » Ven Mai 22, 2015 10:14 am

Salut !

Note : Mon site c'est : uniteailee.shost.ca

J'ai suivi la méthode pour "forcer" le HTTPS :

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^(.*)$ https://%{SERVER_NAME}/$1 [R=301,L]



Mais, quand je rajoute les www , c'est a dire que je vais sur http://www.uniteailee.shost.ca/ , on me redirige sur https://www.uniteailee.shost.ca/ (avec le HTTPS, ce qui est normal) mais le problème c'est que je dois ne pas l'avoir bien configuré, car mon navigateur (Chrome) m'annonce :

Votre connexion n'est pas privée

Il se peut que des pirates soient en train d'essayer de dérober vos informations sur le site www.uniteailee.shost.ca (par exemple, des mots de passe, des messages ou des informations sur vos cartes de paiement). NET::ERR_CERT_COMMON_NAME_INVALID
Retour à la sécuritéParamètres avancés


Que dois-je faire ? ^_^
uniteailee,

Site : http://uniteailee.shost.ca
Contact shost.ca : uniteailee@uniteailee.shost.ca
Contact externe : unite.ailee@gmail.com
uniteailee offline
Avatar de l’utilisateur
Message(s) : 64
Inscription : Jeu Avr 16, 2015 3:52 am

Re: Le HTTPS...

Messagepar Dominick » Ven Mai 22, 2015 10:37 am

Bonjour,

J'ai mis à jour le .htaccess pour que seulement le nom de domaine principal soit en HTTPS.
Code : Tout sélectionner
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteCond %{SERVER_NAME} "uniteailee.shost.ca"
RewriteRule ^(.*)$ https://%{SERVER_NAME}/$1 [R=301,L]


Cordialement,
Portfolio labrie.ca
Administrateur sHost.ca
Statut des services : https://statut.shost.ca/

Desktop NAS | i7 3770k OC | 24GB DDR3 | 500GB SSD & 4x4TB & 12TB HDD & 5TB USB | 700w PSU | ESXi 6.7
UPS 1500VA/900W Backup Battery
Fibre Optique 1Gbps symétrique
MacBook Air 4,2 (2011, 13in) | i5 @ 1.7Ghz; 2 core| SSD128GB | macOS 10.13
Dominick offline
Site Admin
Avatar de l’utilisateur
Message(s) : 1511
Inscription : Ven Juil 27, 2012 11:39 am
Localisation : Fredericton, Canada

Re: Le HTTPS...

Messagepar uniteailee » Ven Mai 22, 2015 11:47 am

Salut,
Merci !
uniteailee,

Site : http://uniteailee.shost.ca
Contact shost.ca : uniteailee@uniteailee.shost.ca
Contact externe : unite.ailee@gmail.com
uniteailee offline
Avatar de l’utilisateur
Message(s) : 64
Inscription : Jeu Avr 16, 2015 3:52 am

3 message(s)Page 1 sur 1

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron