LWS.FR

Site en Zend FrameWork 3

Effectuez vos demandes diverses ici.
3 message(s)Page 1 sur 1

Site en Zend FrameWork 3

Messagepar Sargayn » Lun Juin 26, 2017 1:59 pm

Bonsoir,

J'ai ébauché un site en ZF3, mais j'ai un peu de mal à appréhender sa mise en ligne.
En effet, le FTP présente nombre de fichiers et dossiers, et la page d'accueil de mon compte ( https://stuffrpg.shost.ca/ ) me dit de modifier la page dans le dossier "web".

Avant de poster, j'ai fait une recherche sur Zend dans ce forum, et je n'ai trouvé qu'un sujet de 2013 relatif à IonCube ( https://forum.shost.ca/viewtopic.php?f=6&t=3254&hilit=zend ).

Tout cela me laisse sceptique, et j'aimerai savoir s'il me faut vider le FTP pour y installer mon site, avec éventuellement une configuration spécifique, ou si Zend a définitivement était bloqué ici.

Je vous remercie par avance pour vos réponses,

Sargayn
Sargayn offline
Message(s) : 2
Inscription : Lun Juin 26, 2017 1:49 pm

Re: Site en Zend FrameWork 3

Messagepar Dominick » Lun Juin 26, 2017 7:50 pm

Bonjour,

Il vous manque un fichier index.html ou index.php à la racine du site web.
Sans index, le site web ne fonctionnera pas.

Cordialement,
Portfolio labrie.ca
Administrateur sHost.ca
Statut des services : https://statut.shost.ca/

MSI Z77A-G45 | i7 3770k OC | 24GB DDR3 | 2x128GB SSD & 1TB & 2TB | Sapphire Radeon R9 290 | 700w PSU | macOS 10.12 & Win10
Desktop NAS | i5-3450 CPU | 8GB RAM | 4x4TB & 5TB HDD | CentOS 7
UPS 1500VA/900W Backup Battery
MacBook Air 4,2 (2011, 13in) | i5 @ 1.7Ghz; 2 core| SSD128GB | macOS 10.13
Dominick offline
Site Admin
Avatar de l’utilisateur
Message(s) : 1481
Inscription : Ven Juil 27, 2012 11:39 am
Localisation : Fredericton, Canada

Re: Site en Zend FrameWork 3

Messagepar Sargayn » Mar Juin 27, 2017 2:33 pm

Merci pour votre réponse.

Je n'ignore pas la nécessité du fichier index. Mais dans une architecture Zend, il se trouve dans le sous-dossier "public".

J'ai réussi à obtenir un affichage grâce à une redirection (merci ISPconfig), mais l'URL affiche "/public", ce qui n'est pas bon. Je vais continuer sur cette voie.

Par ailleurs, j'ai tenté diverses approches :
- écrire un .htaccess à la racine du site un niveau au-dessus de web, donc). DOmmage, "permission denied".
- poser le contenu de mon dossier "public" dans "web", et le reste de mon application à la racine du site. Pas plus d'autorisation :(

Ces idées me sont venues suite à votre réponse, et grâce à ce post : http://www.armetiz.info/mise-production-zend-framework-serveur-mutualise/

Ai-je une option pour masquer ce "/public" disgracieux dans mon URL ? (j'avoue, je démarre en gestion de sites, hébergement et toutes ces choses : je n'ai toujours fait que du wed-development).

Sargayn

Édition : Euréka ! Une redirection configurée en type "aucun flag", dossier "/public/", et en ignorant la redirection SEO.
Sargayn offline
Message(s) : 2
Inscription : Lun Juin 26, 2017 1:49 pm

3 message(s)Page 1 sur 1

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron